Application stuck with machine-to-machine type

Hey. I was experimenting with application types and when I set it to machine-to-machine, it’s now disabled and I can’t change it. How can I change it back to regular web app?

Hi @simonlvuong

Thanks for reaching out with your question! I’ve seen this before and this does happen when toggling to M2M app type and saving. You can undo this via the Management API using the Update a Client endpoint. You’ll want to have the application ID at hand and the payload you’ll send will look something like this:

{
“app_type”: “regular_web”
}

That should update your app accordingly and you’ll be back to a regular web application. Let me know if that works for you. If you’re looking for the API token to use, you can always get one if you navigate in the dashboard to APIs -> Auth0 Management API -> API Explorer and copy the Token available on that page.

Best Regards,
Colin Coutts

3 Likes

worked like a charm. at first i was getting 400 error, but i realized it’s because the copied quotes are of the wrong format. it worked once i replaced the quotes with my own instead of pasting them.

1 Like

Perfect to hear that @simonlvuong!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.