Apple Social Connection - Not Working

Hello, I’m trying to add Apple ID login support.

I’ve enabled Apple login through Authentication > Social Connections.

Without making any modifications. I wanted to see if the “Test Connection” button worked with the debug connection strings provided by Auth0.

I received this response.

Is there something else I need to setup? With Google this just worked as-is.

It’s also worth noting that the documentation might need to be updated for Apple Social Connection


This process requires:

An Apple Developer Program account. If you are a member of the iOS Developer University Program, sign up for a free trial.
Lock.js version 11.16 or later if you use the Classic Universal Login Flow or if you embed Lock.js in your application.

There’s no real explanation here what Lock.js is, where it’s located or why it’s needed.

So I found the Auth0-Lock.js Documentation: Auth0-Lock Documentation

Looks like this is for embedded login. I just want to Implement this with Universal Login.

Our recommendation is to use Universal Login instead of setting up SSO in embedded login scenarios. Universal Login is the most reliable and stable way to perform SSO, and is the only way to do so if you must use multiple domains for your applications, or use third-party applications.

My website is already configured for universal login. I’m still left with the question of how to implement Auth0-Lock.js

I did some digging on Auth0’s Community support page and found this thread

In this thread it was indicated that the Classic View of Universal Login utilizes login.js based on some earlier screenshots of their New | Classic view mode.

Great, this is at least a start. Maybe it will get the “Test Connection” button to work as well, nope, nor does it mention anything about Lock.js

Maybe this is a blunder on my part, but I’m sure others have similar questions which is why I wanted to cover my experience in detail as much as possible I’m not not quite sure how to proceed without assistance.

Also, why isn’t there a tag for apple-social-connection under the help category?

Hello @nwhsdev welcome to the community!

The Apple Social Connection should work out of the box with New Universal Login and Auth0 Developer Keys (for testing). I just tested this by deleting my existing Apple connection, creating a new one and enabling a pre-existing app in the Connections tab. I’m able to login via the “Test Connection” option without issue.

Where exactly is this breaking down for you? Which OS and browser are you using?

Keep us posted!

OS: Linux Mint
Browser: Firefox & Chromium

I created a new tenant, added Apple social connect, made sure it was linked to the default application, clicked “Test Connection” same error. Google social connect works fine. I also made sure Ad-block was disabled.

@nwhsdev Did you ever get any resolution on this? We are experiencing the same issue and are baffled. Other connections work fine using auth0 dev creds (Amazon, Google) but Apple will not work for us. We are seeing the same error screen as you.

According to the documentation, you may need a custom domain for “sign in with apple”.

@furu Thanks for the suggestion but on the blog it says that is required when using your own Apple Developer Account - we are simply using auth0 developer credentials currently.