Apple Connection - First Name and Last Name Missing for Some Users

Overview

For some users the first name and last name are missing after authenticating via an Apple connection.

Cause

Check that the Apple connection is configured with the name scope.

  • When the name scope is present Apple will include a name object with the first name and last name of the user in the ID token issued.
  • There is no guarantee that Apple will always send these attributes. Auth0 is unable to check why Apple does not send them, so it is necessary to check on Apple’s side.

There is an issue with Apple where the name may only be sent on the first login for each client ID and not on subsequent logins with the same client ID.

  • If, for example, an Apple connection is configured with the same Apple client ID that is in use on another Auth0 tenant, and a given user has logged in with said other Apple connection already, it is possible the name attribute will no longer be sent in subsequent logins.
  • If there is a login with this same user for the first time in a new Auth0 tenant but with the same Apple client ID configured, the name attribute could be missing.

Solution

When troubleshooting this issue, Auth0 recommends checking whether there is another configured Apple connection with the same Apple client ID in another tenant. If so, check if the user, who has the behavior of missing a first and last name on another tenant, has indeed logged in with this Apple connection already.

Alternatively, try creating a new client ID and secret pair on the Apple side, update the Auth0 connection with the new pair, and see if the issue still occurs.