An account with the email already exists

I just signed up to Auth0, downloaded the Nodejs sample app from “Applications → Default App (Regular Web Application) → Quickstart”, updated the .env file and tried to sign up. The verification code goes through to my email fine, but when I enter I get the message: “An account with the email already exists.”, even though I have no users in “User Management → Users”. Any ideas what is going on?

Hi @Sunny2,

Welcome to the Auth0 Community!

I have just checked your tenant and found that you have 0 users and that there are no error logs regarding the “An account with the email already exists.".

Could you please clarify if you are still having issue?


Hi Rueben

I just tried again and it didn’t work, so I tried clearing my browser cache for localhost:3000 and this time the UI was slightly different and it did indeed let me sign up. However, after clicking sign up then entering an email address and password I am get a screen with the below text at the url https://dev-***************************

Authorize App
Default App is requesting access to your dev-
**** account.

  • Profile: access to your profile and email

This is not what I was expecting, the previous flow (before I refreshed my cache) would also ask for a username, then take me to a screen to input the verification code, which what I was expecting. The above text seems to imply the user already has some account that my app is trying to link to.

Any ideas what is going on? Like I said, I’ve just downloaded the Nodejs sample app (it was contained in a folder called 01-login) and updated the .env file.

Hi @Sunny2,

Thanks for the update.

If you are seeing the consent screen, that is normal. If you prefer to skip the consent screen, please toggle on the Allow Skipping User Content in your API settings (Dashboard > Applications > APIs > Your API).

Not to mention, if you accept consent, it should bring you back to your app’s callback URL.

I looked at your connection and branding settings and see that your users can only log in with a username and password, and not with a verification code. The verification code may be happening from MFA if you had it enabled previously, but I see that it’s disabled at the moment.

If you are still encountering the email already exists error, it may be worth deleting the user and then trying to sign up again.

Please let me know how this goes for you.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.