Auth0 Home Blog Docs

Adding Auth0 to an existing Objective-C project. (xcode9/iOS11)

error
migration
xcode
objective-c

#1

![alt text][1]

(im using the latest cocoapods,xcode,sdk)

When I try it with xcode 8.x, as this message suggest, after the migration I got compile errors in _ObjectiveManagementAPI.swift like this:
init method: “Cannot invoke ‘users’ with an argument list of type ‘(token: String)’”.

(xcode 8.3.3,sdk 10.3,pod 1.0.1, auth0 1.8.0, simplekeych 0.8.0)

I know i do it wrong somehow, but cant figure it out… :confused: Thanks for any advise!
G.


#2

Long shot, but you mention the use of latest cocoapods, but then you state that pod version is 1.0.1. I just ran pod --version on an up to date install and it declares version 1.3.1 as latest. You may want to update to see if it can be related.


#3

Thank you so much!
That did the trick on the older machine. So xcode 8 could merged it to swift3.
Now the project can be opened by xcode 9 on the other machine with the latest software tools installed.
My english is knowledge is not enough to tell you how thankfull I am right now :slight_smile:
Thanks agan @jmangelo !

The real issue is here, when you have to use Auth0 without XCode 8. The cocoapod is swift 2 and in xcode 9 is no option to upgrade it to swift3 or swift4…
(When will apple stop playing around with the syntax?!)


#4

Thank you so much!
That did the trick on the older machine. So xcode 8 could merged it to swift3.
Now the project can be opened by xcode 9 on the other machine with the latest software tools installed.
My english is knowledge is not enough to tell you how thankfull I am right now :slight_smile:
Thanks agan @jmangelo !

The real issue is here, when you have to use Auth0 without XCode 8. The cocoapod is swift 2 and in xcode 9 is no option to upgrade it to swift3 or swift4…
(When will apple stop playing around with the syntax?!)


#5