Auth0 Home Blog Docs

Adding a custom social connection to a client

wordpress
slack
custom-social-connec

#1

Hey there, I run a small Slack Community on a free plan and want to enable my users to access a yet to build wordpress site with restricted access. I set up the Auth0 Wordpress Plugin and established a connection to my Slack using Custom Social Connections. I can’t use the SSO because the Settings are only accesible on a paid Slack Plan… :wink: The Custom Social Connection worked fine (the Test checks out), but I can’t add it to my Client. Could anyone point me in the right direction?


#2

Hi!
If you intent to use Slack as the “source of truth” for users and give users the ability to “log in with Slack”, then you are on the right track of creating a custom social connection. For this, you need to create an App in Slack, which appears to be available for free plans. If you already created and tested the custom social connection, I would say you are almost there.

You don’t need “SSO” on Slack, this would only be required if you wanted users from an external source to sign in into Slack. Say, for instance, that you have a company and you want every user from your Active Directory to SSO into Slack.

In your case, after you created your custom social connection to Slack, this becomes a way of authenticating users. Then, on clients (such as on the client that represents your WordPress plugin), you enable the connections that you want. If you want users from the Slack connections coming to your WordPress site, you would enable the Slack connection to the WordPress client.

Does that make sense?


#3

Makes perfect sense. :slight_smile: Thanks. I figured as much (well not the SSO Part obviously lol).

Only Problem is I can’t add it to my Wordpress Client. I can’t enable it in the settings? I am probably lost in the menus somewhere. Let me show you my settings:
alt text

The Slack “Test” is a success, I can login on the “Try” Button. So thats properly configured.

But where can I choose Slack as a connection???
alt text


#4

Nevermind - i figured it out. I had to add “slack” as option within the plugin. And had to struggle with a few other things. Works like a charm now. Thanks again!


#5