Account linking extension not linking two accounts with same email

Problem statement

We are using the Account Linking Extension and are having issues linking two accounts that have the same email address.

Cause

  • Currently, the Auth0 Account Linking Extension (both in Rules and in the back end) searches for identities with the same email address with the GET /api/v2/users-by-email endpoint. While this endpoint is very efficient, the search it performs is case-sensitive .

This could be a problem for some Enterprise identity providers that provide the email address in a capitalized form (e.g. John.Doe@acme.com instead of john.doe@acme.com ).

Solution

At the moment, this is a limitation of the Auth0 Account Linking Extension, though there is a backlog item to address this issue.