400 Error when Creating a Password Change Ticket via Management API

Overview

When creating a password change ticket through the Management API endpoint outlined in Create a password change ticket, the 400 error below may be encountered. This error occurs when adding the user’s required matching data to the body. This article explains a potential cause and solution.

400 Payload validation error: ‘Invalid property user_id’

Applies To

  • Management API

Cause

The 400 error is usually triggered when both user “user_id” and “email will” are included, resulting in a 400.

Solution

For a successful 201 response using this Management API endpoint, the body must contain either:

"user_id"

"ttl_sec"

or

"connection_id":

"email":

"ttl_sec":

See Create a password change ticket for more details on this endpoint.