"You forgot to wrap your component in <Auth0Provider>" only in built application

I have a react application using auth0-react and react-router-dom. I use getAccessTokenSilently() from useAuth0() to add a token to API request headers. I also use user from useAuth0() to display the user name on the top banner.

All of this works correctly when running the application locally with the “vite” command. However, when building the application with “tsc && vite build” and then running it locally from the dist folder using “vite preview”, as well as when this is done to deploy the application to the cloud, the following error is produced when calling getAccessTokenSilently(): “You forgot to wrap your component in ”. This call is nested many layers deep, however the username derived from useAuth0 is still displayed correctly, showing that my Auth0Provider is still working.

I have tried different approaches to requesting the token, like doing different parts in useEffect and providing different dependencies, and attempting to wrap the components making the request directly in another instance of Auth0Provider. Some of these methods still work in development but none work in the built version. Additionally, I have tried getting user from useAuth0() at the same time but that returns undefined when/where I have this issue, even though the banner still shows the username.

This builds to a single .js and .css file, and inspecting the react components in chrome react devtools it looks like everything is inside of the Auth0Provider. Any help resolving this would be appreciated.

Hi @mschersten,

Welcome to the Auth0 Community!

Here’s a couple of threads that provide additional context on the error you’re seeing. If you don’t find an answer here, can you please share some code snippets of your implementation. Don’t include any sensitive data.

Hi Dan,

Thanks for the reply. I have reviewed just about every mention of “you forgot to wrap your component” I can find on Google. Again, this does work using “vite dev” to run the application directly from the unbuilt application in src/, and it’s only in the built application in dist/ with “vite preview” that I have the issue. I’ll see if I can reproduce the issue in a more bare-bones example of it, but this seems to be related to react-router-dom.

We are using react-router-dom v6 with createBrowserRouter() and <RouterProvider>, like this:

const AppRouterProvider = ({ routes }: AppRouterProviderProps) => {
  const { getAccessTokenSilently } = useAuth0()

    const getToken = async () => {
      const token = await getAccessTokenSilently()
      return token;
  const router = createBrowserRouter(routes)
  return <RouterProvider router={router} />

That getToken() is successful in both the dev and preview version, but any requests made in a route only work in the dev version.

When I look at the components in chrome react devtools I see that everything is contained within my Auth0Provider:


This is identical in both the dev and preview version. Any advice about how to debug this would be appreciated.


This exact problem we are having too and we are on auth0 ^2.2.3

Did you happen to fix this issue?

Even if we wrap our main component with <Auth0Provider> at the root level in React, we will probably encounter this error when attempting to retrieve the getAccessTokenSilently at the same level. This occurs because we wrap our App with App` , causing us to obtain the token at the child component.So we can only get the getAccessTokenSilently at children not the same page.

So I did this way :

  1. Create a 2 seperate compoenent
  2. Wrap main component with my component


import { AppState, Auth0Provider, User } from "@auth0/auth0-react";
import { useNavigate } from "react-router-dom";

type Props = {
  children: React.ReactNode;

function Auth0ProviderWithNavigate({ children }: Props) {
  const domain = import.meta.env.VITE_AUTH0_DOMAIN;
  const clientId = import.meta.env.VITE_AUTH0_CLIENT_ID;
  const redirectUri = import.meta.env.VITE_AUTH0_REDIRECT_URI;

  const navigate = useNavigate();

  if (!domain || !clientId || !redirectUri) {
    throw Error("Unable to initialize auth0. something missing");
  const onTheTimeThatRedirecting = (appState?: AppState, user?: User) => {

  return (
        redirect_uri: redirectUri,

export default Auth0ProviderWithNavigate;


<Route path="/auth-callback" element={<AuthCallbackPage />} />


import { useCreateUser } from "@/api/MyUserApi";
import { useAuth0 } from "@auth0/auth0-react";
import { useEffect, useRef } from "react";
import { useNavigate } from "react-router-dom";

const AuthCallbackPage = () => {
  const { user } = useAuth0();
  const { createUser } = useCreateUser();
  const navigate = useNavigate();

  const hasCreatedUser = useRef(false);

  useEffect(() => {
    if (user?.sub && user?.email && !hasCreatedUser.current) {
      createUser({ auth0Id: user?.sub, email: user?.email });
      hasCreatedUser.current = true;
  }, [createUser, navigate, user]);

  return <>Loading......</>;
export default AuthCallbackPage;

main.tsx Wrap your main component with coustom