Wrong username and password error when switching to new universal login experience

Last Updated: Dec 4, 2024

Overview

Wrong Username or Password error for confirmed correct credentials.

Database Login is not possible when switching to the new Universal Login Experience, even though it works when using the old experience.
The new one always gives out error:

Wrong Username or Password

Applies To

  • Database Login
  • Password
  • Universal Login Experience

Cause

As New UL also uses the default directory setting (like ROP flows) this can cause a change in behavior from the Classic experience, resulting in a different connection that supports active authentication being used when a database connection is expected for example.

Solution

Steps to Reproduce

  1. Set a default directory to a supported connection type (auth0-adldap, ad, auth0, email, sms, waad, or adfs - e.g. an Azure AD connection).
  2. Use New Universal login with identifier + password auth profile.
  3. Enable more than one connection for the test application, i.e. a database (intended login) and Azure AD connection.
  4. Attempt to login using database credentials - default directory will be used.

Troubleshooting

Check the tenant default directory setting and enable connections for the application in question.

Ensure that the default directory is either not set, or set to the desired database connection. Enterprise connections should be accessible via HRD or by rendering as a button.