Auth0 Home Blog Docs

What are the restrictions on domain in GetToken in auth0-python?

If I run the following script (with the variables set), then everything is happy and I get a token.

from auth0.v3.authentication import GetToken

creds = { ... }

get_token = GetToken(creds['domain'], telemetry=False)

token = get_token.client_credentials(
    creds['client_id'],
    creds['client_secret'],
    creds['audience'])

print(token)

If I then run the same script, but I also delete some of the characters in domain (e.g. just take the string xxx-xxxxxxxx.xx.auth0.com and replace it with say xxx-xxxxx.xx.auth0.com deleting a couple characters), then when I run the script I still get a token back that seems to work. So basically my question is, what is the restriction on domain here? Why is it being specified at all instead of having some fixed auth0 sub-domain?

Here is information about my system. I am running debian 10 and have python3 installed from the repos. The auth0 package is installed in a virtual environment:

$ pip3 freeze | grep auth0
auth0-python==3.9.1
$ python3 -V
Python 3.7.3
$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:    10
Codename:   buster

Thanks for any help!

P.S. I presume that issue is at least partially that I don’t understand oauth or certain basic ways that auth0 is implemented. Or I’m simply posting in the wrong place. In that case, please let me know…