Auth0 Home Blog Docs

Using auth0 and oauth2 to do a google assistant app




oauth2 access token expires in 1 hour.

I need this to last forever, that is, to keep renewing itself automatically


As mentioned before, you need to refer to the access_token documentation, and specifically the lifetime section which talks about the refresh token which you will need to request.

BTW: per our documentation for tokens:

The default value is 24 hours ( 86400 seconds). The maximum amount of time (in seconds) that the token can be valid after being issued is 2592000 seconds (30 days).

That SO link is not for us - it’s for Google.

Please avail yourself this documentation to assist you.


I do that (I put 2592000) but not solved


Why I don’t have this


No idea, though I would suggest you verify that you’re not looking at the Auth0 Management API and instead are looking at the API you create. It appears just fine for me:


I would like you to look at the screens below and guide me if auth0 can help me:

Nick Felker from google asked me to look at OAuth 2.0 Playground

Do I can use OAuth 2.0 Playground results in auth0?


what am i doing wrong that no option appears to activate offline access?


The screens you show reference things that Auth0 does not support and we are unable to provide support on them.

As stated already, you need to create your own API and use it, not the Auth0 Management API, via the Create API button. I can’t help you out much more than that.

Again, you’re trying to do something that we don’t currently support and using guides and references for things that are not ours nor can we provide support for them. I suggest following the instructions to Create API and then work from there.


I change my scope from


and I am following the result between today and tomorrow,
thank you now


not solved yet I do’n’t know why


@jeremy.meiss Hi, you said: As stated already, you need to create your own API and use it, not the Auth0 Management API, via the Create API button

and I ask: Why when I create api Auth0 Management API, via the Create API button I can’t
have Allow Offiline Access toggle button option?

Do you have a easy tutorial to create api to use in auth0?


The Auth0 Management API is meant to be used by back-end servers or trusted parties performing administrative tasks. This API is separate from the publicly accessible Auth0 Authentication API, which is meant to be used by front-ends and untrusted parties.

You create those publicly accessible APIs via Manage:

You will then have the option to allow Offline Access to that API. The Auth0 Management API is only to be used for managing (hence the name) / performing administrative trasks. All other activities will be handled by the publicly accessible endpoint you setup, where you can setup Offline Access.

Again, we do not currently support your use case as you have explained it, and are trying to do things which are coming from other non-Auth0 resources.



now you know more about my problem and I know more about auth0

I have question (s):

The problem faced by jess in the link below, is not the same or similar to mine?

Do you think @jmangelo answers would be useful?


I don’t know if they would be useful or not. The user followed his suggestions and contacted the project(s) he was trying to use. I have suggested you do the same. I am not sure that we can help you any further on this seeing as this use case is not something we support (as has been stated).

It seems that you are pulling at straws trying to get things to work, and going in many different directions. One suggestion I have for you is that you start over with what you are trying to do now that you (hopefully) have created the API necessary for offline_access. It may be that you find something you have missed. Any issues you have in the process I then suggest you work directly with the tutorial makers and/or github repos that you’re using.