Users Received Blank Screen during Silent Authentication using Safari & IOS Browsers

Last Updated: Dec 17, 2024

Overview

Users encountered a blank screen when trying to log out in Safari or IOS browsers.

Applies To

  • Silent Authentication
  • Safari
  • iOS

Cause

This was happening because the usage of the canonical domain to make the call was interpreted as third-party compared to the custom domain.

To troubleshoot the issue:

  • Check /authorize call and check if cookies auth0 and auth0_compat were sent.
  • Check if the /authorize call is sent from the Canonical Domain or the Custom Domain.

Solution

Update the application code with the custom domain.