Users received blank screen during silent authentication using Safari & IOS browsers

Problem Statement

Users encountered a blank screen when trying to log out in Safari or IOS browsers.

Troubleshooting

  • Check /authorize call and check if cookies auth0 and auth0_compat were sent.
  • Check if the /authorize call is sent from the Canonical Domain or the Custom Domain.

Cause

This was happening because the usage of the canonical domain to make the call was interpreted as third-party compared to the custom domain.

Solution

Update the application code with the custom domain.