URL error with login button

Hi! I’m trying to use Auth0. I follow the tutorial step by step but when I click on the ‘login’ button, this appear on my url:

http://localhost:3000/?error=invalid_request&error_description=no%20connections%20enabled%20for%20the%20client&state=MGttT0czcmcyNGQ5QTVGUTRVLWEzUlN0X1p1cHdHZDN1dm9sTWVfNkhHUg%3D%3D

And when I trying to verify my account with your email link, this appear on the url

All its failing, what can I do? Do you can help me?

Thanks!!

Hi @aarrom ,

Welcome to the community!

The first error is due to the client_id you are trying to login into has no connections enabled. If you open up the application in your tenant dashboard (Applications > Applications on the left hand side), there is a tab for connections, here you can toggle on connections you wish the client to use, such as an Auth0 database or Social Login like Google with OAuth2.

The second error is because the verification link is a single use link, it may have been double clicked, or you have an email scanner that is issuing a GET to the page before you can click on it, but the first time that link was used it should have successfully verified the email.

2 Likes

Thanks for helping on this one Steve!

I don’t know if this is in the tutorial for beginners, but I didn’t see it

Thanks a lot!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.