Unable to Process Redirect Callback

Last Updated: Aug 7, 2024

Overview

When trying to configure the redirect from the Action and upon sending the user back to Auth0 (resuming the authentication flow), the following error occurs:

“Unable to process redirect callback. This is often caused by calling the /continue endpoint with an invalid state parameter.”

Applies To

  • Redirect Callback
  • Action

Cause

As per the error description, the error is often caused by calling the /continue endpoint with an invalid state parameter. However, the same error can also occur under the following circumstances:

  • The user initiates the login flow using the default auth0 canonical domain, but when sending the user back to /continue endpoint using the custom domain (or vice-versa)
  • The user spends more time on the page they are redirected to than allowed by tenant session configuration.
  • The account that the user just logged in with is linked as a secondary identity before the call to /continue.

Solution

  • Make sure that the flow uses the same domain.
  • Make sure the session timeout is greater than the user spends on the redirected to page.