“Unable to issue redirect for OAuth 2.0 transaction” using a database connection (but Social Provider works)

SPA using VueJS. The social login/signup (via Google) works, but the database signup fails.

Logs:

{
  "date": "2020-08-07T16:59:55.828Z",
  "type": "f",
  "description": "Unable to issue redirect for OAuth 2.0 transaction",
  "connection_id": "",
  "client_id": "WpMthRCXFGP2Tsrbk6VRJjq2yhUYQ2WE",
  "client_name": "Revuud",
  "ip": "71.241.129.38",
  "user_agent": "Chrome 84.0.4147 / Mac OS X 10.15.5",
  "details": {
    "body": {
      "state": "g6Fo2SBnRnJDcXFMeWR0SzRPcjJTN0ptWk1FVmVOR3hPUk5rVqN0aWTZIDhDODZlOEJkZ1k4d193S1hpQVhOVGRid2JnOEFRNEZEo2NpZNkgV3BNdGhSQ1hGR1AyVHNyYms2VlJKanEyeWhVWVEyV0U",
      "audience": "https://dev-revuud.us.auth0.com/api/v2/",
      "scope": [],
      "action": "accept"
    },
    "qs": {},
    "error": {
      "message": "Unable to issue redirect for OAuth 2.0 transaction",
      "oauthError": "server_error",
      "type": "oauth-authorization"
    },
    "session_id": "6SvfsfJv2mZp61ECO2JpEX_z7C0rSqu4"
  },
  "hostname": "dev-revuud.us.auth0.com",
  "user_id": "auth0|5f2d888832cea3022114884f",
  "user_name": "matthew@example.io",
  "audience": "https://dev-revuud.us.auth0.com/api/v2/",
  "scope": [
    "openid",
    "profile",
    "email"
  ],
  "log_id": "90020200807165957584000617839962835810446817300297285634",
  "_id": "90020200807165957584000617839962835810446817300297285634",
  "isMobile": false
}

This is a test on localhost. The user is created, but this error is generated and the generic “Auth0 something went wrong” page is displayed.

Hey @matthewmcneely, Welcome to the Auth0 Community!

This error indicates most likely indicates some issue in the redirect_uri in the initial /authorize issued
by your application. The Authorization server failed to issue a redirect on that URL. Will you be able to check that on your side?

Please let me know if this helps.

Regards,
Sid

I’m having a similar issue, except my login was working about a day ago. Nothing with regards to login has changed so I am a little confused whats up (maybe a service outage?)

Can you reproduce that now?

Yup. Here is my Auth.js

export default class Auth {
constructor(history) {
this.history = history;
this.userProfile = null;
this.auth0 = new auth0.WebAuth({
domain: process.env.REACT_APP_AUTH0_DOMAIN,
//audience: process.env.REACT_APP_AUTH0_AUDIENCE,
clientID: process.env.REACT_APP_AUTH0_CLIENT_ID,
redirectUri: process.env.REACT_APP_AUTH0_CALLBACK_URL,
responseType: “token id_token”,
scope: “openid profile email”
});
}

login = () => {
this.auth0.authorize();
};

handleAuthentication = () => {
this.auth0.parseHash((err, authResult) => {
if (authResult && authResult.accessToken && authResult.idToken) {
this.setSession(authResult);
this.history.push("/");
} else if (err) {
this.history.push("/");
alert(Error: ${err.error}. Check the console for further details.);
console.log(err);
}
});
};

As soon as i try to login i get a error on your Auth0 page with the failed to redirect.

So we have been doing more testing and it seems like it works on incognito but not normally.

Edit: No longer working on incognito too

Got it solved. It was a broken callback url. However I am unsure why G Suite login worked - seems like an application safety issue if not fixed.

1 Like

Glad you have eventually figured it out!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.