Auth0 Home Blog Docs

The client was not found: undefined


#1

Using ws-federation. After the first login, if the redirect happens again I get the error:

invalid_request : The client was not found: undefined

If I remove the “auth0” cookie that is set for my application domain (i.e. https://app.auth0.com), it starts working again.


#3

Hey there @darren.gillis!

I’m not sure if I understood you correctly. So you are able to login for the first time and then if you log out and want to log in again you get such error, is that correct? Thanks for providing a few more words for clarification!


#4

Hi @konrad.sopala,

There was no explicit log out action. The client application browser closed and so the cookie stored locally for the client app expired and so on next client login, the redirect takes place over to auth0 and this is when the error occurs.


#5

Thanks for clarifying that! That is quite unexpected. Have you got such behaviour after following tips from our content on setting up ws-fed?


#6

Hey there Darren!

Have you managed to solve the issue by now or do you need any further help?


#7

We possibly have it figured out, still working through some scenarios. Thanks


#8

Great to hear that @darren.gillis! Will be great if you can share your solution with the rest of the community so that others can learn from your case.

Thanks a lot!


#9

I had the same issue after updating an application with new urls.

Turned out that I forgot to update the settings in the Addon: WS-Fed (WIF) Web App; the Application Callback URL and the Realm were still pointing to the old urls. I updated all the settings of the application, but forgot that you also have a configuration screen behind the WS-Fed add-on “button”. After updating the urls in the WS-Fed add-on config everything works as expected.


#10

That was basically my issue as well. I was using the ws-fed endpoints located in the “advanced settings” and didn’t notice the Add-On.


#11

Thanks a lot @darren.gillis and @p.blommendaal for contributing knowledge to the issue!


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.