Auth0 Home Blog Docs

Suppressing Tenant Accept Screen

login
tenant

#1

When I sign up a new user, I see this:

![alt text][1]

Is there any way to suppress this. I have multiple clients configured but for the app that is using this it’s not a multi-tenant situation as far as auth0 is concerned.

How can I suppress this? Thanks.


#2

That is the consent screen; a few things to have in mind about it:

  • when the authentication request contains an audience value associated with an API that you configured then it will show depending on the toggle Allow Skipping User Consent configurable at the API in question.
  • when the authentication request is for the https://{your_domain}.auth0.com/userinfo the allow skipping user consent toggle is enabled so the consent screen will only be show for third-party clients or if you’re running your application in localhost; see these docs for more information.

It’s highly likely that your client is a first-party client (you can make sure by checking the value of the is_first_party option through the Auth0 Management API; it should be true) so if you’re running this in development and using localhost that would be the cause of it.


#3