[Solved] jwksError: Not Found thrown during GET request with auth bearer token to protected api

An error - “jwksError: Not Found” is thrown when I make a get request with the correct bearer token in the request header to my protected API. I’ve followed the start up guide to create the checkjwt helper function that I pass to all my routes to protect them. I need help clarifying what this error actually means thanks!

Defining the checkJWT helper function with help from quickstart guide.

Protecting API with checkJWT to ensure auth token is correct and passed in request header.

GET request sent with postman and corresponding error thrown by jwks-rsa module.

I’ve fixed it! The error was way too ambiguous but after desperation set in, I checked my configs again and I found that I included a “/” at the end of my auth0apiIdentifier, this allowed a “//” in the jwksUri which caused the issue. Solving this typo was my fix.

Check your code guys! Peace!

1 Like

Glad you have figured it out and thanks for sharing it with the rest of community!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.