SOLVED: GitHub social connection, Auth0 dev keys work, my own keys return no data

I’ve added the GitHub social connection, and want to use it as one of several options for logging into a service I’ve created.

When I used Auth0’s dev keys when calling GitHub things work and I get back the email address etc of the user authenticating with GitHub. Nice.
But: When I use the OAuth app credentials I’ve created in GitHub, I can authenticate without issues, but I don’t get any email address or other user info in the callback to my own service.

I’ve triple checked the client ID of the GitHub OAuth application - it matches the one entered in Auth0’s GitHub settings.

Any ideas of what could cause this?

Hi @mountaindude,

Welcome to the Community!

Are you getting a successful response? This may have to do with the scopes you are requesting.

Also, can you DM me your tenant name so I can take a look at the settings and logs.

Yes, getting a successful response both when using Auth0’s dev client id/secret and when using my own. Just that I don’t get anything back when using my own id/secret.

The scopes could very well be involved, but it’s also a bit strange as I don’t change any of my client side code at all. But admittedly - I am using Passport.js and there could very well be something going on in there too, somehow making a difference depending on what id/secret is passed it. A bit far-fetched, but certainly possible.

Will try passing in different scopes to see if it makes a difference, and DM you the tenant name.


…and it’s solved.

Turned out to be a scopes issue after all.
Simply passing in a scope of

scope: ‘openid email profile’

solved the whole thing. All good!

1 Like

Glad you got it resolved!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.