SAML callback from SP responded "The InResponseTo attribute does not match the id in the AuthNRequest"

Hi All,

I was having issue getting the callback to work properly.
First of all, here is my setup based on(Test SAML SSO with Auth0 as Service Provider and Identity Provider)

  1. Created IDP on Auth0
  2. Created SP on Auth0
  3. We host the login page by ourselves using Django
    Then calling the /authorize endpoint using the Management API
    Management API set with proper callback URL + IDP Initiated SSO enabled
    Tried with response_type either code / token as well, not working
  4. Proper X509 cert configured

The authorize endpoint was redirected properly to IDP successfully just that when calling back to our own Django platform URL, it return with error parameters.

Trial and error with Custom domain not using auth0 endpoint, it’s not working, getting same error. Many reference said it was because localhost. But created a proper domain to test it, it was not working as well.