React Tutorial Broken

Hi all,

It looks to me like the React Tutorial and sample code is just broken.

Starting with a completely fresh application, I can download the sample code and follow the instructions to a tee, but I always wind up with the same Authorization Error from Google.

The error reads:

Authorization Error
Error 400: redirect_uri_mismatch
The redirect URI in the request, https://<my_handle>.us.auth0.com/login/callback, does not match the ones authorized for the OAuth client. To update the authorized redirect URIs, visit: https://console.developers.google.com/apis/credentials/oauthclient/{your_client_id}?project={your_project_number}

Seeing as I don’t have the project number or Client ID that Auth0 used to create the OAuth application on GCP, I can’t get GCP to change the redirect URI. And without access to that same project, I can’t tell what the actual URI is supposed to be.

This is both the case for the sample app provided by the Quickstart download, and following the Quickstart tutorial from scratch. Surely someone else has encountered this? I’m starting with a completely fresh account. I’ve also deleted my Auth0 app and started over a number of times, to make sure I hadn’t incorrectly configured the application.

  • Which SDK does this apply to?
    Latest.
    @auth0/auth0-react@^1.0.0
    @auth0/auth0-spa-js@^1.9.0

  • Which version of the platform are you facing this error on?
    Latest.

  • Was this code working before? Have you made any changes in the dashboard recently?
    Wouldn’t know, I’m a new user.

  • Please capture and attach the stacktrace, it helps a lot!
    N/A. Node server did not produce a stacktrace.

  • Please share the code that is causing the error.
    N/A. This is directly from the React SPA tutorial.

  • Can you share a minimum reproducible?
    Answered above.

  • Please capture and attach a HAR from the browser if this is an Authentication Bug / Issue.
    Attached.
    accounts.google.com_Archive [20-10-14 23-26-31].har (1.2 MB)

Hi @robbiemckinstry,

Did you change the google connections settings at all? The client id and client secret?

Hi @dan.woda ,

Thanks for the reply.

I did not. Both the client ID and the secret ID are uneditable in the UI for me. The boxes are grayed out and I cannot change the values in them.

They should just be blank if you haven’t added any keys. Can you post a screenshot or DM it to me if it has sensitive info?