Previous User Still Logged In: SAML Enterprise Connection to Microsoft Entra ID (Azure AD) SP-Initiated flow

Problem statement

With SP-Initiated flow, try to log in as user1@example.com while the user logged in to Microsoft Entra ID (Azure AD) as user2@example.com, but the user still logged in as user2@example.com.

Cause

This is expected behavior since the user has a session with IdP as user2@example.com.

Solution

The user needs to do a federated logout from IdP first and then log in with the new email address (In this case, user1@example.com). Refer to the Log Users Out of SAML Identity Providers guide for more information.

Related References