OKTA different okta domain for different requests

I’m trying to use the okta api. I was able to use the api to create an authorization server and access policy with my okta domain.

The problem started when I tried adding a rule to the policy. When I tried adding a rule with my regular okta domain which looks like this: dev-1345678.okta.com, I got a 200 response but no rule was actually added to the policy. I then checked the request through the browser when adding one through the api and noticed that they’re using a different okta domain which looks like this: https://dev-1345678-admin.okta.com. Only when I used that domain did I get a 201 request instead of 200, and the rule was actually created.

How do I know when I need to use the domain with the “admin” in the url and when not?

Hi @babubanti999

Welcome to the Auth0 Community!

It looks like your inquiry is related explicitly to Okta rather than Auth0 (which is a separate product under the Okta brand). Since this forum focuses on Auth0 you might more specialized assistance on the https://devforum.okta.com/ .

The Okta community is a great resource for questions about Okta-specific implementations and features. They have a wealth of knowledge and experience that would be more relevant to your current project.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.