/oauth/token endpoint ingores connection property when used with password grant

Hello There,

I’m trying to use the /oauth/token endpoint to get the access_token using the passwordless connection strategies. This works only with one of them at a time(either sms or email) - Defined in Settings /General / API Authorization Settings / Default Directory.

My expected behavior would be that I could specify it in each request like this:

{ client_id: '...',
client_secret: '...',
grant_type: 'password',
connection: 'email', // !!!
username: '...@....com',
password: '...',
scope: 'openid' }