Auth0 Home Blog Docs

Not able to log in, not sure why.



Here is the error I keep on getting

TypeError: Cannot read property ‘0’ of undefined
at Strategy._verify (/Users/mikel/Code/personal/swim-puffer/server/index.js:64:45)
at /Users/mikel/Code/personal/swim-puffer/node_modules/passport-oauth2/lib/strategy.js:191:24
at /Users/mikel/Code/personal/swim-puffer/node_modules/passport-auth0/lib/index.js:134:7
at passBackControl (/Users/mikel/Code/personal/swim-puffer/node_modules/oauth/lib/oauth2.js:134:9)
at IncomingMessage. (/Users/mikel/Code/personal/swim-puffer/node_modules/oauth/lib/oauth2.js:157:7)
at emitNone (events.js:91:20)
at IncomingMessage.emit (events.js:185:7)
at endReadableNT (_stream_readable.js:974:12)
at _combinedTickCallback (internal/process/next_tick.js:80:11)
at process._tickCallback (internal/process/next_tick.js:104:9)


Could you share a snippet of your authentication code?



I do not think its in the code.

So I am working on this project with a friend, we had Auth0 hooked up and working on his account just fine. we tried switching it to the new account and it would throw this error. all we did was change the .env file with the new domain, clientID, and Client secret.


Because that didn’t work I then tried switching to my personal account to see if the issue would continue. after changing the .env file again to my accounts information it worked great. so Auth0 works with the code we have on mine and my friend’s account, but when we try to use the Gmail account set up for the project, it doesn’t work.

I don’t see how it could be the code when Auth0 works correctly on my auth0 account, my friends auth0 account but not the new account