No connections enabled for the client SSO, on new Universal Login

Continuing the discussion from No connections enabled for the client, but SAML connection is enabled:

The end solution to this was to: “You will have to enable the “Display connection as a button”, you can do this from your SAML connection > Login experience tab in the Dashboard.”

However, I want to point out that this is really a no-go for most apps. Because that means that it will show the screen “Login via … for X” for all of your enterprise clients that have a SAML connection. That can easily be in the hundreds.

First, it’s not user friendly to show a whole list of those and letting the user find their company on that list. And second, that would leak the clients.

Note that this only happens on the new universal login. The classic one works fine.

Did the team get to the bottom of this issue?

Since the new universal login only asks for the email address at first, the other option is to add the client domain into the ‘Identity Provider domains’ section.
This works for me and (as you point out) it’s waaaaay better than having a thousand buttons for individual customers.