Newbie question for app settings - Callback URL mismatch

Hello,

I have the following sample multi docker container setup for authentication using Auth0 and to pass JWTs to the backend APIs.

https://github.com/lcahlander/multi-container-nginx-react-existdb

I have the following settings:

Application type: Regular Web Application
Token Endpoint Authentication Method: None
Application Login URI: blank
Allowed Callback URLs: http://localhost/_codexch
Allowed Logout URLs: blank
Allowed Web Origins: blank
Allowed Origins (CORS): blank

I am getting the following page when I try to open localhost

Any help would be appreciated. This is to be an example implementation to the eXist-db community for implementing SSO with JWTs being passed to the backend.

Hey there @loren.cahlander welcome to the community!

This typically happens when URL you’re redirecting to in your app is not listed as an Allowed Callback URL in the App Settings in your Auth0 Dashboard.

Are you able to confirm that the URL you are redirecting to post authentication is indeed added correctly? Aside from that, what happens if you define your redirect URL with a port and add that to your app settings as an allowed callback URL? Thinking http://localhost:3000/_codexch

Let us know!

1 Like