Auth0 Home Blog Docs

Multiple passwordless SMS connections

Hi,

We have two SMS gateways and would like to use them for two different Auth0 apps/clients.
To achieve this, we created via Auth0 management API two passwordless SMS connections, each pointing to its own gateway. Next, for each connection we added a corresponding client to its enabled_clients list. In https://manage.auth0.com/dashboard everything looks good. Each client has its own SMS connection enabled. The client which uses the SMS connection that was created first, works fine. But when we try to signup via the second client, Auth0 reports the following error to its logs:

Type: Failed Signup
Description: connection is disabled (client_id: xxxxxx - connection: sms)
Connection: sms

“sms” is the name of the first connection, which is indeed disabled for the second client.

The questions are:

Why does Auth0 try to use the connection that is disabled for the client, instead of the one that is actually enabled?
Does it rely on specific connection name (i.e. “sms”)?
Is it possible to get multiple passwordless SMS connections working under one Auth0 account/tenant?

Thanks.

Hey there @a.zolotko and welcome to the Auth0 Community!

I am currently looking into your questions and will respond back with what I find. Thanks!

Hey @a.zolotko, I wanted to follow up after checking with our team. After working to recreate the scenario in our test environment we were able to successfully create two SMS connections as well.

From there after diving deeper into the problem you referenced it appears it’s not setup to use two SMS connections by default (thus always failing to the first connection). What we would recommend trying is to leverage a conditional statement in Lock to differentiate between connections/SMS pairings (Example: IF Connection 1 use SMS 1 ELSE use SMS 2). Please give this a shot and let us know if it helped resolve your issue or if we need to take another look at it. Thank you in advance!

I wanted to follow up on this @a.zolotko and see if you were able to move forward on this front? Thanks!

Hi James. Sorry, I haven’t had time yet to try the solution you’ve proposed. It’s in my backlog however, and I’ll report you back as soon as I try it.

Sounds great, thanks @a.zolotko!