Auth0 Home Blog Docs

Missing location hash on login only on iOS devices (prod, Angular4 running on Apache, bitnami)

apache
auth0
angular4
ios

#1

I’m currently running a MEAN website on Amazon’s Lightsail, which has bitnami MEAN preinstalled. I’m running the node server on a screen process, and I have Angular4 code prod compiled and running on the installed Apache Web Server.

Authentication with Auth0 works fine in all cases except for with iOS devices, there is no location hash with the login information. When I run the website locally I successfully login - I receive the location hash on iOS devices (locally I run it using ng serve, not apache, I tried in development and in --prod, both were fine).

As mentioned in other posts (Hash get’s lost on Safari/Webkit browsers), I’ve added a front slash to my redirect url, it made no difference.

Has anyone else encountered this issue?


Hash missing on Safari, also Chrome for iMac
#2

For those in the same situation as I had been myself, The issue was the combination of Apache Web Server and iOS’s Safari. Now that I use Nginx instead, the problem does not occur anymore.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.