Missing Custom Attributes in Zendesk when Using SSO Integration

Overview

Some custom Auth0 user attributes are missing in the Zendesk user profile when using the Zendesk SSO integration.

Applies To

  • Zendesk SSO integration

Cause

Zendesk SSO integration does not support outgoing custom user attributes.

Solution

While it is not possible to configure custom fields with the integration, it is possible to configure Auth0 as a SAML IdP as described in Manually configure SSO integrations.

The instructions also include how to configure SAML on the service provider side (Zendesk in this case). The SSO integration uses SAML, so it should be very similar.

Once this is set up, configure mappings in the add-on settings with the key as the Auth0 attribute name and the value as the outgoing attribute name, as shown below:


Please see here for further details: Map SAML Attributes with Auth0 as IdP/SAML Add-on