MFA token not genarating can help any one?

i tried to enable google authenticator in auth0 for exsting user using api , so fr that i tried to generating mfa token using mfa api but its getting error like username and pwd wrong but every thing i scorrect can any one hekp on thisI tried to enable Google Authenticator for an existing user in Auth0 using the API. However, when attempting to generate an MFA token through the API, I encountered an error stating that the username and password were incorrect. Despite ensuring that all credentials were accurate and correctly formatted, the error persisted. Could anyone provide assistance with this issue?
below is the sample code

curl --location ‘
–header ‘Content-Type: application/x-www-form-urlencoded’
–header ‘Cookie: did=s%3Av0%3Ac6012c90-d55b-11ee-9845-c7bc7c3500f4.6J8%2BnH9lyJmfzouqWE%2FklDiagFJc4F6Wqw01yUg%2FBVE; did_compat=s%3Av0%3Ac6012c90-d55b-11ee-9845-c7bc7c3500f4.6J8%2BnH9lyJmfzouqWE%2FklDiagFJc4F6Wqw01yUg%2FBVE’
–data-urlencode ‘content-type=application/x-www-form-urlencoded’
–data-urlencode ‘grant_type=password’
–data-urlencode ‘’
–data-urlencode ‘password=Welcome@123’
–data-urlencode ‘client_id=Tvb6coaianLuWT9VEmHkxB6aSOioBg7z’
–data-urlencode ‘client_secret=IJ4A96i7zPVsbyobD_8KDzkolWes_yiIM1kFf7y5t7rM02j6wRUKrI1_9ijgYku’
–data-urlencode ‘audience=
–data-urlencode ‘scope=openid profile’