Managment api update issues

Hi, I am new to auth0 so i ll try to explain the best I can:
I am using the auth0 api for the management of user(create delete update…) the thing is when I try the update i have multiple issues.
frist i cant update multiple properties at the same time (like email and username, password and email, etc…)
second i tried then to modify only fiew properties and it worked when i used the auth0 api directly but when i try with my code or even with postman it send me a badrequest (for postman the bad request was “not found”) even though Im doing the same thing that i did directly with auth0 api.

PS: I did the same for the delete action i sended a request and it worked(in my code and postman with the same parameters) thats why i dont get the reason behind that “not found”.


Hi @psr11140 ,

Welcome to the Auth0 Community!

In your screenshots, there is no Authorization key. Could you please get the Auth0 Management API access token and add the key for both requests in Postman and try again?

Hope this helps!

Hi, thank you for the reply, but unfortunetely it didnt work. actually the header authorization was there before too, i just didnt scroll to display it .

it is weird because i tried again with other action like the get method and it works it found the user with the id.

and the update method in the auth0 api works fine with the same token, body and id i used in postman.

So i still dont understand why it doesnt work with the update method.

Just noticed that in Postman, you used the PUT request. Actually it should be PATCH. Could you please give it a try?

yes that was the issue , it works now, thank you for the help.