Login Error "Not Found" Appears after Configuring the Java Spring Boot Application

Overview

When logging into the Spring Boot application and hitting the authorize endpoint, the error message not found appears.

  • The authorize request endpoint that causes the error message is: /oauth2/v1/authorize
  • The login flow sporadically works, and when it does, the authorize endpoint used is: /authorize
  • This QuickStart guide was used to configure the Java Spring Boot application

Applies To

  • Java Spring Boot Application

Cause

The problem is caused by a failed configuration request to the /.well-known/openid-configuration endpoint on app startup. When this request fails, the Spring Boot OAuth2 client library sends the login request to /oauth2/v1/authorize instead by default.

Auth0’s quickstart implements the okta-spring-boot library that presents the above behavior.

Solution

Please try the below steps:

  1. Confirm that all dependencies align with what appears in the documentation. Here are the dependencies.
  2. If the issue reappears after the app is restarted or a new version is deployed, the recommendation is to use tcpdump or a similar tool to check the traffic being sent/received; this should help confirm what is happening with the configuration request (call to /.well-known/openid-configuration endpoint) and where it is being blocked.
  3. From Auth0’s side, it is unlikely that the configuration request would be blocked. This issue is most likely occurring at the firewall or OS level. There must be some condition that blocks this configuration request when a new version of the application is deployed to the server or if the application is restarted. But if the issue persists and tcpdump shows that the request is reaching Auth0, and the Auth0 replies with an error, please reach out to Auth0 Support.