Auth0 Home Blog Docs

iOS Swift: remove auth0.com from Signin with Google page and consent dialog social login with auth0.com

Hi Team,

I am facing 2 issues while implementing facebook/google login with Auth0 in my app.

  1. I want to remove “auth0.com” from Sign in with Google page.

  2. I am trying to use Facebook/Google third-party login with Auth0 in my app. Everytime I am trying to initiate a log in from the app and when I want it to open up the facebook/google app for login, it first displays a dialog asking for user consent: [App] wants to log in with “auth0.com” This allows the app and website to share information about you.
    Is there any workaround to implement this functionality without showing this dialog.

Please provide solution for above problem.

1 Like

Hi kamlesh-hcl, and welcome to the community! :partying_face:

  1. In this situation, I think your only option is a custom domain: https://auth0.com/docs/custom-domains though I have not personally tested this myself so I cannot guarantee it will produce the results you are looking for.

  2. I don’t know enough about your architecture to answer this question definitively. However, if you’re using a first party API with a web app, and this is what is producing the user consent screen, you can go into the API settings and there is a toggle for “Allow Skipping User Consent” which should skip this. If you’re running an app on localhost, this won’t work because localhost is not a verifiable 1st party API, but once you go to production the user consent should be skipped.

If you’re using an iOS app, then the issue is likely with iOS itself, and cannot be fixed. Please see this thread: iOS Swift - Remove consent dialog social login with auth0