Invalid state after adding permissions to API (using Nuxt 3)


Maybe this is a rookie question but I have browsed on the web for a while and haven’t found a similar issue.

I added 2 new permissions to one of my API’s and since then I can’t log in anymore without being hit with “Invalid state” error. I haven’t changed anything else and I even tried removing the recently added permissions but the application is now broken and it is no longer possible to log in. I have tried clearing browser cache, and cookies but with no success.

I am not sure what I am missing here but why would adding permissions cause invalid state error when logging in? And in any case it should be able to revert? What can I do to fix this (I really need those permissions but even more importantly, I need to get the app running again)

Edit: I don’t know if related but I notice that every time I attempt to log in, I log both the query params and the auth0 client and the state inside the transaction manager is different from the state in the params. Does anyone know why and what can be done?