Invalid_request Sign-In Error to App using Organizations

Overview

This article explains the cause of an error that occurs when a user attempts to sign in to an application that uses the Organizations feature. The error is returned as a query parameter in the callback URL.

invalid_request - no connections enabled for the organization are visible

https://example.com/callback?error=invalid_request&error_description=no%20connections%20enabled%20for%20the%20organization%20are%20visible&state=...

Applies To

  • Organizations
  • Enterprise Connections
  • Universal Login

Cause

The Universal Login experience requires at least one visible connection for an organization to be presented to the end user. This error occurs when an organization is configured with only Enterprise connections, and the Display connection as a button option is disabled for all of them.

While Database or Passwordless connections have an inherent User Interface (UI) for credential entry, an Enterprise connection does not have a UI representation unless the button is explicitly enabled. Without any visible connections, the login flow cannot proceed and returns the error.

Solution

To resolve this issue, enable the display button for at least one Enterprise connection within the organization.

  1. Navigate to the Management Dashboard.
  2. Go to Organizations and select the target Organization from the list.
  3. Select the Connections tab.
  4. Select the Enterprise Connection that should be visible to users.
  5. In the settings for that connection, select the Display connection as a button toggle to enable it.