Introduction to Django 3.0 - Building, Authenticating, and Deploying - Part 2

Thanks for following up on that Vihar!

1 Like

image

Could someone help me here?
followed all steps in tutorials/blogs
also i have changed the urls that they are supposed to directing to, but it doesn’t work…
this is on a production site

What tutorial and blog you mean? Have you followed precisely all the steps mentioned in this article (which is the article of this thread):

yes i have followed that blog post u have attached both part 1 and 2, @konrad.sopala

1 Like

I am getting this too, i think the document is outdated and needs a re_path or something in urls.py. Followed every step precisely

Thanks for reporting all that. Tagging @holly for visibility

When I click Log In, I am getting a Callback URL mismatch. The provided redirect_uri is not in the list of allowed callback URLs. error.

I have http://localhost:8000/complete/auth0/ under the Allowed Callback URLs.

Hmm it seems that it’s what the blog post suggest. Can you share the screenshot of your allowed callback urls field?

Hi @konrad.sopala,

Please see the screenshot of the error:

I definitely added the callback urls for this app:

Also, I have the accurate domain, client id, and client secret keys in my .env file.

Any ideas on what else I can try? Thanks!

hmm, have you tried putting it after coma but in one line?

Hi Esther!

I’m new to the setup myself, and I might be wrong here, but I had the same error and used http://127.0.0.1:8000/complete/auth0 instead. It works now.

Hi Shivam,
Thank you for the tip. I tried it but bumped into an error:
AuthMissingParameter at /complete/auth0/ Missing needed parameter state

Did you add include a parameter?

Thank you for the reply.
I did try this but I am still seeing the same error.

Hi Esther,

Sorry but I did not add any parameters. I found this documentation that describes the error:

https://readthedocs.org/projects/python-social-auth/downloads/pdf/latest/