In Rules, ipv6 IP address comes [sorry, resend]

I want to check IP address whitelist, so I get context.request.ip.

Until October 5th, it was ipv4 address.
Since October 5th, it is ipv6 address.

Because ipv6 address changes everyday, I cannnot check IP address whitelist.

It maybe happens only free plan account.
What happen??

It happened when “password reset”.
The plan didn’t matter.

1 Like

Hey there!

Thank you for reporting that. Let me test and confirm that and get back to you soon with the news I have.

Thank you for investigating.

sorry.
It was not the effect of a password reset.

Suddenly I was able to pick up the ipv4 address, and suddenly it became the ipv6 address.

It seems to be different depending on the connected person, not the account, so it may be due to my network.

1 Like

okok gotchya! Can you then try analyzing it on your end and troubleshoot where it might be coming from?

Hey there!

Have you had a chance to check my previous message?

Ping ping friendly ping :slight_smile:

context.request.ip in Rule may expose IPv6 address due to our ongoing edge network migration. New edge network supports both IPv4 and IPv6 address. There are no settings available to disable this functionality. If you are processing or have some sort of allowList in Rule, please ensure that you are checking with the correct version of IP.

The range_check library for example has a version method that should make this a fairly trivial check to implement. It should be as simple as including a version check before attempting any matches. See https://www.npmjs.com/package/range_check#version for more information.

1 Like

Thanks @tanver.hasan for sharing that!