IDX20803: Unable to obtain configuration from: 'System.String'. on real iPhone

Hi everyone!

I am trying to use Auth0 with our Xamarin (Native) application, but I faced strange behaviour on iOS. At first I added all necessary code. Our application uses .NET 6, so I pulled repo with client for iOS and ported it to .NET6 (Do you think that this can cause the problem?). Then I tried it on a simulator and everything was fine. But when I started it on the real device I got next exception : "IDX20803: Unable to obtain configuration from: ‘System.String’. " which I can’t fix for today. (Exception throws after I press continue on login page)

I have tried next things:

  1. Added permissions for background fetching and set AppTransportSecurity exceptions in info.plist
  2. Tried to run all flow on UI thread
  3. Also I had suspicion for Linker, but I couldn’t run it with Link All mode
  4. Tried to access well-known openId configuration for our domain (It works ok in both cases)

Have somebody faced same problems or know where to look?