I need help with log in error OP_Query

I have a problem. From one moment to another this error comes out when i try to log in with auth0:

Unsupported OP_QUERY command: find. The client driver may require an upgrade. For more details see https://dochub.mongodb.org/core/legacy-opcode-removal


I’m having the same issue. It’s due to the mongodb package version (mongodb@3.1.4) being used. Is there a way to upgrade this to V5?

1 Like

I have the same issue, how is it possible to upgrade ?

I am also having the same issue.

I am having the same issue as well. This is very frustrating, has anyone found a solution?

I think is a problem from auth0. Multiple people having the same problem from one second to another.

Im using mongodb v6.0 and still the same. I have everything update and suddenly all people start getting this message. I think is a problem of auth0 not from us. But i dont know how to talk to them or where to reach them.

Support just helped me resolve this issue. Simply change the driver version to mongodb@4.1.0 in your custom database functions. :grinning:

I am able to resolve the issue. Change the Node version to 16 from tenant settings and then change the driver version to 4.1.0


Thanks Sayanth
actually updated my autho extensibility to Node 16, and then database action script with 4.1.0 still have the issue :frowning:

Actually after restarting it works !
with the fix you provided.

I already have node 16 and mongodb 4.1.0 but still the same error in auth0 password log in

I have the version 16.15.1 of Node and the version 4.1.0 of mongo:

├── mongodb@4.1.0
└─┬ mongoose@6.10.5
└── mongodb@4.14.0

But still getting this error of OP_Query

Sigo pensando que el problema es de Auth0. Me tira el error incluso sin tener el servidor levantado. Cualquier otro dato del servidor me lo trae perfecto incluso usando find. Pero lo unico que falla es la contraseña de auth0. Es un problema de auth0. Pero soporte no responde.

I fixed it by updating my Rules to

const { MongoClient } = require(“mongodb@4.1.0”);

Then it worked

instead of using mongodb@3.1.4

hope it helped :slight_smile:

1 Like

Thanks for sharing @kim.nguyen, that is the fix indeed :white_check_mark: I apologize we weren’t able to get to this sooner!

I dont have mongoClient i have this:

const mongoose = require(“mongoose”);

And even without start my server the auth0 is still failing.

The solution is to pay a plan for auth0. In free plans they stop supporting external database. So if you recieve this error and you have a free plan is becouse you are no longer able to connect to mongo for free.

I’m haveing the same problem but only when I call the management api to update a user for the email verification, why are the db scripts working but not the update user api?. What do you mean that mongodb in no longer in the free tier? Where can I find more information about this?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.