I cannot setup password in Auth0 dashboard

Hey there guys :slight_smile: am setting up a single page app in the Auth0 dashboard and I would like to allow people to sign up by password but when I go to the “advanced” tab in the Aut0 dashboard I am not allowed to chose password. I am getting the following error:
Error!

Application must not have Token Endpoint Authentication Method set to “none” when client_credentials grant type is enabled.

I have setup: http://localhost:3000 and the url where it will eventually be deployed to : “Allowed Web Origins” and “Allowed Origins (CORS)”

is there anyone Here who knows why this is? :slight_smile:
thanks in advance
Linda

Hi @lindamacdonald,

Welcome to the Auth0 Community!

Do you want to let your users log in with a password and email, or do you want to use the password grant? These are two very different things.

@dan.woda thanks a mil for getting back to me, I appreciate it :slight_smile: appologies for the fluffy question. I am after the grant but cannot do it because both the Client Credentials andToken Endpoint Auth Method “none”" are both autoselected for me so I cannot add the password grant

What type of application have you set up (Native app, SPA, regular web app, etc.)? Did you create a new application and follow these directions setting it up?

Hey there Dan :slight_smile: the only difference in my setup in relation to the tutorial is that I set up a SPA and not a regular web app so perhaps that is the problem here? I am integrating Auth0 in a react/next.js app. Ill see if it works with a regular web app :slight_smile: