How to change Auth0 error message?

Auth0 universal login shows an error “could not open popup” on mobile and safari web browser.
You could refer to this.

I am going to update the error message to “Check popup permissions in the setting”.
Please let me know how to figure this out.

Hi @david.yang,

I’ve taken a look at our code and it seems that this is not configurable because the error message is currently hardcoded: auth0-spa-js/utils.ts at v1.13.6 · auth0/auth0-spa-js · GitHub

As far as I know, it would require a code change for that library. I would suggest submitting your feedback to our Product Team so they can evaluate its implementation: Product Feedback - Auth0

1 Like

Hi @Ale .
Thanks for your help.
Btw, can I avoid the popup error still using loginwithpopup method by allowing the browser popup permission dynamically or by other way?

I don’t think that’s possible, @david.yang. Being able to change the browser (client) settings programmatically by a third-party web application would raise many security concerns immediately.

2 Likes

Exactly! That’s right!

1 Like