Auth0 Home Blog Docs

How to add a post-login redirect url?

Instructions for SPA webapp are outdated, I think

Looking at the control panel, I clicked on ‘quick start’ to have a boilerplate to study.

It uses

  // Starts the user login flow
  login(customState) {
    webAuth.authorize({
      appState: customState
    });
  }

in the auth service, and, in the router

auth.login({ target: to.path });

But in the api doc this option is not mentioned at all, and, also, this generates a console warning about appState is not an accepted parameter.

I need, using vue, to simply add a redirect url.

Hi @realtebo and welcome to the Auth0 Community!

I just ran a fresh vue app from our quickstart download to see if I could recreate the issue and did not run into any problems. I can make the app redirect off the callback and it seems to work okay.

A couple of questions:

  • Were you logged in when you downloaded the sample application (they come pre configured with client id and require no editing)?
  • Did it run okay without modifying anything?
  • How are you configuring the redirect?

Thanks,
Dan

Hi, thanks for the reply, but

  • Yes, I downloaded the sample application
  • It run okay, BUT the default app show (just a flash before redirect to login screen) the same warning
  • Yes, all is configured

To reproduce, simply download vue quick start app, then in chrome devtool set network speed to lowest you can. Login, then, after succesfully redirect to demo app, goto http://localhost:3000/profile and press Ctrl-F5

You’ll see this.

I tried to reproduce by following your instructions but I am getting no error. Could you DM me a screen shot of your application settings in the Auth0 dashboard?