Help with api to api set role to user

good morning! sorry for the inconvenience. with a question that may be a little silly. I have a problem assigning a role to my user. I am using the test from Auth0 Management API v2
and in my path it asks for my user ID. When I put it I get this error

"statusCode": 400,
   "error": "Bad Request",
   "message": "Path validation error: 'Object didn't pass validation for format user-id-with-max-length: 114552882084658623149' on property id (ID of the user to associate roles with).",
   "errorCode": "invalid_uri"

I am passing the user_id. What could be wrong? again sorry for the inconvenience

Hello @hugo127sanchez !

No worries, happy to help :slight_smile: Hmmm, judging by the error it seems to be an issue with the user id param passing validation - Does the id you’re passing look something like this: auth0|622bc004a1712a00699ff0f0 ?

hello good! I had not tried putting auth0| I was only passing the id part. I’ve tried it and it worked wonderfully. Thank you very much for the help!

1 Like

No problem, happy to help - Thanks for confirming!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.