Grant type '' not allowed for the client

Problem statement

We are getting the error “Grant type ‘’; not allowed for the client.” In our application settings we see a checkbox for the “Password” grant type, but not ‘’. How can we enable this grant type?


This can usually happen when the ‘password’ grant is enabled in the client (application), but not ‘’.

When you turn on the ‘Password’ grant type via the dashboard - under the Advanced Settings of the application - both of these get turned on. However, it’s possible to turn on only one via the Management API.


If you turn the ‘Password’ grant type off → Save → and then again → Save in the dashboard, you will get both grants working.

If that does not work for some reason, you can also update the client via the Management API. Auth0 Management API v2

Specifically, the “grant_types” array should have both the following grant types (and any other you need additionally):

  "grant_types": [
    // ... any other additional grant types

The order of the array does not matter.