Google Connect warning on Instagram-App

Hello Everybody!

We have discovered a problem. When users click on our registration via an Instagram add or our page there and want to connect to Google Connect, they get an error message.

“Access blocked, the request from Holistic violates Google’s guidelines: Use Secure Browsers”

The message comes after the user typed in his credentials. It seems that the internal Instagram browser does not appear to be secure for Google. Makes sense, too.

The question is: Can I hide the GoogleConnect only in the Instagram context? Or is there an other solution?

Hi @n1c0

Welcome to the Auth0 Community!

You are right; Google OAuth does not work with embedded web views per policy. → Modernizing OAuth interactions in Native Apps for Better Usability and Security - Google Developers Blog

You can utilize the GET /authorize endpoint to direct the user to the specific ODIC connection by specifying the connection parameter. This should bypass the Universal Login prompt. Authentication API Explorer

I hope this will help you!


Hey Dawid!

Thank you for your quick response and the idea to fix it :smiley:

It would be great to set a parameter to get only the “email/password” registration-form without connections. Can I achieve this with the authorize endpoint?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.