Auth0 Home Blog Docs

GitHub Extension Error "Schema validation failed loading"?

Github extension V.2.5 just stoped working and getting this error:

Error:

Schema validation failed loading [
    {
        "keyword": "required",
        "dataPath": ".emailProvider",
        "schemaPath": "#/properties/emailProvider/required",
        "params": {
            "missingProperty": "name"
        },
        "message": "should have required property 'name'"
    }
]

Any help will be appreciated

2 Likes

I just started receiving this error today as well.

2 Likes

For what it’s worth, I’ve also encountered this issue today; I created a new application+repository, set up the extension and webhook, using the guide in the docs, and this error is what I saw when I tried to push my first commit.

1 Like

I’ve been working with the Auth0 Support team and it sounds like there might be a solution to this issue soon.

@zach.mckenzie , @FSQuaratiello Yes just confirmed its working . Thank you guys for your comments.

2 Likes

Glad you have it all working now!

It seems like the following error shows whenever I click deploy on my tenants. Must be a back-end/status problem since it worked perfectly before today.

Schema validation failed loading [
    {
        "keyword": "required",
        "dataPath": ".emailProvider",
        "schemaPath": "#/properties/emailProvider/required",
        "params": {
            "missingProperty": "name"
        },
        "message": "should have required property 'name'"
    }
]

Hey @user792!

Can you check it once again? It should be working for you by now. The issue has been solved. Some of our users who also reported it got it working:

Thanks!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.