GitHub Deployments extension not working on Node 12

I created a new tenant today, and the installation of the GitHub Deployments extension was failing consistently with the following error:

{
  "code": 400,
  "message": "Compilation failed: Cannot find module 'auth0-source-control-extension-tools@4.0.5'\nRequire stack:\n- /data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js",
  "error": "Cannot find module 'auth0-source-control-extension-tools@4.0.5'\nRequire stack:\n- /data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js",
  "stack": "Error: Cannot find module 'auth0-source-control-extension-tools@4.0.5'\nRequire stack:\n- /data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js\n    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:793:17)\n    at Function.WebtaskModule._resolveFilename (/data/sandbox/lib/module.js:96:21)\n    at WebtaskModule.require (/data/sandbox/lib/module.js:154:37)\n    at require (/data/sandbox/lib/module.js:189:17)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:22878)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:27674)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:97187)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:104372)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:40111)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:41291)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:106167)\n    at t (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:177)\n    at /data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:560\n    at Object.<anonymous> (/data/io/9ce6a17d-77e3-470a-8e06-a241ad317846/webtask.js:1:571)\n    at WebtaskModule.compileWebtask (/data/sandbox/lib/module.js:147:32)\n    at defaultJavascriptCompiler (/data/sandbox/lib/compiler.js:135:24)\n    at defaultCompiler (/data/sandbox/lib/compiler.js:144:12)"
}

I ended up learning how to change the Node version through the tenants settings here: Trying to create Bitbucket deployments

I’m guessing this is related to recently deprecating Node 8 in favor of 12. But wanted to report this issue in case others run into it as well. (Based on two other community posts, seems like this is possibly a recurring problem with Auth0 during Node version upgrades, and it would be nice to have a better experience.)

Thanks for reporting it Tommy! Bringing it to attention of the responsible team!

1 Like

Same error here :v:
Downgrading to Node 8 solved the issue although you have to reinstall the extension

1 Like

Hey there!

Thank you a lot for reporting that. For future reference, please create a GitHub issue in the repo and share the link to it with us here. We’ve passed that information to the appropriate team. Here’s the repo for that:

1 Like

Konrad, do we watch here for updates on this? I see that Auth0 hasn’t opened their own ticket on the repo you linked to, so I don’t have anything to follow over there.

That said, it looks like the actual issue is that auth0-source-control-extension-tools@4.0.5 needs to be added to the Node 12 image (see https://auth0-extensions.github.io/canirequire/#auth0-source in Node 12 mode - there is no 4.0.5, only 4.0.3).

The team is working on that. I’ll let you know once I have any updates to share

2 Likes

Is this now addressed? I see that canirequire suggests that version 4.0.5 (and 4.0.6 and 4.0.7) is now available…

Let me reach out again to the team and get back to you shortly!