getTokenSilently always has login_required on page refresh

I’ve so far never managed to get the session based getTokenSilently to work on a page refresh, it always requires login_required. I’ve tried both with username/password style account and google login account. It’s happen both on my staging site (see attached HAR) as well as my localhost.

It relates to browser as it never works on Chrome 79 but is fine on Safari. Looking at dev tools, I can see cookies to auth0 “did” and “did_compat” being blocked. There are various other cookie warnings about SameSite=None and sso (screenshots can be provided on request)

I’m at wits end trying to debug and resolve this and could use some direction! (2.8 MB)

Some additional info… for Chrome, I’ve never managed to get this to work. The HAR was created in incognito mode.

For Safari, on a fresh Safari run (never visited auth0 nor the site before), it page refresh worked the first time but silent auth fails later on.

Bump… any other information I can provide to get some advice?

Thanks in advance